COMPATIBILITY:

FSX, FSX-Steam, P3D v.3.xx, P3D v.4.xx+

Ho dear user. You can donwload latest EZCA which compatible with P3D 4.5.

Link to download....

Also we start adapt old version 2.8 for P3D 4.5 It can take up to 1 week. 

Please be patience.